18
Vote

"Your views must implement IView"

description

I'm using the latest beta converged version.

If I create a new page and change its base class to VisualStateAwarePage (in XAML and .cs) and add prismMvvm:ViewModelLocator.AutoWireViewModel="True" to the XAML, Visual Studio underlines it and errors with "Your views must implement IView". If I run the windows phone emulator, it works anyway which is weird. This is also the case with the Adventure Works Shopper reference implementation. This only happens with the windows phone project selected.

I am still able to debug the app anyway, it's only once I open the file in the designer that the error pops up.

file attachments

comments

Robert23 wrote Jan 31, 2015 at 4:42 PM

Have the same issue in a simple Desktop Application.
public partial class DocumentViewTest : UserControl, IView